Help with Video #6 - Serial I/O Echo Routines

General discussions related to the Altair 8800 Clone

Help with Video #6 - Serial I/O Echo Routines

Postby alfonzo » November 10th, 2019, 12:25 pm

I am having lots of fun playing with my Altair 8800 clone. As a newbie I am trying to follow along with the excellent videos. However video 6 has me stumped.

https://youtu.be/70l6CE0mWbs

When stepping through the program, when the input instruction on port zero executes, not only does D0 go to one, but the entire data bus goes to one. I.e. D0-7 are all one. It seems that the input instruction itself is correctly executing since the INP indicator is on. But for some reason D0-7 are all one as well.

I have tried entering the program multiple times, but always get the same result. I am pretty sure that the connection is okay because all other videos have worked until now and I even was able to do some basic serial communication between my clone and my TI-99/4a. I even turned on my old Acer laptop and connected directly to an old serial port instead of using a USB to serial adapter just to be sure, but I keep seeing the same behavior.

Any ideas for a newbie would be appreciated. Thanks!
alfonzo
 
Posts: 3
Joined: February 8th, 2017, 2:18 pm

Re: Help with Video #6 - Serial I/O Echo Routines

Postby AltairClone » November 10th, 2019, 8:45 pm

The video is accessing an 88-SIO at I/O address 0. Sounds like you’ve got the 88-2SIO at I/O address 20 (octal) enabled instead. Go into the configuration monitor and enable the 88-SIO port at 0.

Mike
AltairClone
Site Admin
 
Posts: 421
Joined: April 5th, 2013, 10:55 am


Return to General Discussions

Who is online

Users browsing this forum: No registered users and 1 guest

cron