Can't save files

Discuss construction, troubleshooting, and operation of the Altair 8800c computer

Can't save files

Postby toml_12953 » September 28th, 2021, 5:08 am

I have an 8800c I built myself. It's been running great up until now. I have the FDC+ board in it with the full 64K mod described on page 5 of the manual.
The FDC+ is set to use my two HD 5.25" floppy drives as 8" Altair disks.
I just updated the FDC+ firmware from version 1.3 to version 1.7 and, after a hand from Mike Douglas, the update seemed to go perfectly.

The system is using Altair Disk Extended BASIC ver. 300-5-F.
I can mount and unload with no problem. I can execute the FILES and LOAD commands for both drives 0 and 1.
What I can't do, however is SAVE a BASIC program! When I try, the BASIC OK prompt reappears quicker than it should with no error message.
When I try to find the file on the disk, however, it's not there. If I try to SAVE using a filename already on the disk, that filename disappears from the disk.

I may try to revert to FDC+ firmware 1.3 if I can find it anywhere to see if the problem goes away. All I can find online is 1.6.

Any ideas what might be happening?
toml_12953
 
Posts: 244
Joined: June 7th, 2013, 12:54 pm

Re: Can't save files

Postby toml_12953 » September 28th, 2021, 7:04 am

toml_12953 wrote:I have an 8800c I built myself. It's been running great up until now. I have the FDC+ board in it with the full 64K mod described on page 5 of the manual.
The FDC+ is set to use my two HD 5.25" floppy drives as 8" Altair disks.
I just updated the FDC+ firmware from version 1.3 to version 1.7 and, after a hand from Mike Douglas, the update seemed to go perfectly.

The system is using Altair Disk Extended BASIC ver. 300-5-F.
I can mount and unload with no problem. I can execute the FILES and LOAD commands for both drives 0 and 1.
What I can't do, however is SAVE a BASIC program! When I try, the BASIC OK prompt reappears quicker than it should with no error message.
When I try to find the file on the disk, however, it's not there. If I try to SAVE using a filename already on the disk, that filename disappears from the disk.

I may try to revert to FDC+ firmware 1.3 if I can find it anywhere to see if the problem goes away. All I can find online is 1.6.

Any ideas what might be happening?


It looks like I have more investigating to do. I found an old copy of FDC+ firmware 1.3 and flashed that. Went to BASIC and, voila! I was able to save and load OK.
I got brave and upgraded to firmware 1.6, tried that and, again, no problem saving and loading. Well, I'll be brave just to prove the problem is actually 1.7.
I flashed 1.7, started BASIC and, OOPS! I was still able to save and load programs! The problem was NOT with 1.7. Now I have to figure out just what happened yesterday
that prevented me from saving a program properly.

BTW, Does anyone know how to use the PIP program that comes on the Altair BASIC disks (not the CP/M version)? I get ERR no matter what parameters I use.
toml_12953
 
Posts: 244
Joined: June 7th, 2013, 12:54 pm

Re: Can't save files

Postby AltairClone » September 28th, 2021, 10:51 pm

For info about Altair PIP in BASIC, see page 124 of the Altair BASIC manual here https://deramp.com/downloads/altair/sof ... l%2077.pdf

It’s a miserable and slow program. A disk format takes about 10 minutes and a disk copy takes about 30 minutes from what I recall.

Mike
AltairClone
Site Admin
 
Posts: 487
Joined: April 5th, 2013, 10:55 am


Return to Altair 8800c

Who is online

Users browsing this forum: No registered users and 1 guest

cron