Altair on simh linux requires B image

General discussions related to the Altair 8800 Clone

Altair on simh linux requires B image

Postby coldoch » March 6th, 2019, 3:38 pm

Hi Folks,

I've been trying to do some of my Altair C/PM programming on linux, since its my portable solution.

I tried using the CPM dsk images, and all would fail with messages like:

$ altair
Altair 8800 simulator V3.8-1
sim> attach dsk0 cpm63k.dsk
sim> go
63K CP/M
Version 2.2mits (07/28/80)
Copyright 1980 by Burcon Inc.
Bdos Err On A: Bad Secto

Anyway, I eventually tried the CP/M image that is called version "B", and this works flawlessly under simh for linux. And it also reads the disks like zork.dsk etc.

Can anyone tell me what the difference is?

Posts: 1
Joined: March 9th, 2018, 5:48 am

Re: Altair on simh linux requires B image

Postby AltairClone » March 7th, 2019, 9:49 am

Simh works fine with all Altair disk images I've every used, including the Burcon CP/M, so I'm not sure what you're up against.

Delete all of your simh content and try the simh package I've put together here:

Site Admin
Posts: 417
Joined: April 5th, 2013, 10:55 am

Re: Altair on simh linux requires B image

Postby TomXP411 » March 7th, 2019, 12:49 pm

Also, you might check out Altair32 and look at building the the Altairduino emulator.

Altair32 works pretty well, although there are definitely some quality of life improvements I'd add in (such as remembering mounted disks.)

Altairduino can be compiled on Windows, Linux, and presumably MacOS (I haven't tried it on a Mac yet.) You just have to use the standalone mode, where you use the bottom row of the keyboard to emulate the front panel switches while in the monitor.
Posts: 39
Joined: March 8th, 2018, 4:13 pm

Return to General Discussions

Who is online

Users browsing this forum: Google [Bot], MSN [Bot] and 5 guests