Page 1 of 2

New here, some questions

PostPosted: April 26th, 2015, 6:12 am
by harnas
Hi everybody, I'm Luis, from Spain.

I got my Altair Clone few days ago, and I've been having so much fun with it.

I have some questions, there are some little things I still couldn't figure out. Don't worry, I'm sure they are going to be easy to answer, since they are coming from a completely newbie :)

1) When I use the 8KBASIC, it works great but there are some characters missing if I write a program and then list it. For example, yesterday I wrote a little program to calculate the factorial of any number:

5 I=0:N=0:Z=0
20 FOR I=1 TO N
30 Z=Z(LOG(I)/LOG(10))
50 PRINT N;"!= ";10^(Z-INT(Z));" E ";INT(Z)

And here is what appears when I list again the program:

5 I0:N0:Z0
20 OR I1 O N
30 ZZ(OG(I)OG(10))
35 EXT I
50 RINT N;"!= ";10(ZNT(Z));" E ";NT(Z)

As you can see, every first letter from every word is missing, together with some symbols like -,=,/... When I run it, it works perfectly, so I guess inside the Altair's memory the listing is OK. By the way, I just have this issue with the 8K BASIC (didn't try the 4K one). Both MBASIC under CP/M and Disk BASIC run perfectly.

2) How do I load 4K BASIC from tape? I tried the bootstrapping listing from the original manual, and then I rise the A12, A9, and A8, the same way it's done with the 8K version. So far I couldn't make it load this.

3) Is there a way to copy .BAS files inside an Altair DOS image? Something similar to PCGET under CP/M.

Well, that's all, for now :)

Re: New here, some questions

PostPosted: April 26th, 2015, 9:08 am
by AltairClone
Question 1:
Looks like you're usng HyperTerm. Eventually you'll want to look into TeraTerm as provided in the Clone support package as HyperTerm doesn't work as well with vintage computers as TeraTerm.

HyperTerm is discarding characters with the MSB set. Fix this by choosing properties, choosing the settings tab, clicking the ASCII Setup button, then checking "Force incoming data to 7-bit ASCII"

Question 2:
If you're trying to load 4K BASIC v3.2 (i.e., not 4.0), then the sense switch settings are different for this version of BASIC than for the v4.0 products. To load v3.2 from cassette, you'll set A15 on (use cassette), then set A11 and A10 on (console is 2SIO with one stop bit)

Question 3:
You can mount a BASIC disk in the 2nd and/or 3rd drive when booting and running Altair DOS from drive zero. The COP utility can then be use to copy files between the BASIC disks or onto the DOS disk. You'll find this an extremely cumbersome process compared to CP/M and clearly see why Altair DOS (and stand-alone BASIC) went nowhere and CP/M took off!


Re: New here, some questions

PostPosted: April 26th, 2015, 3:47 pm
by harnas
Thanks for your quick response :)

I managed to load 4K BASIC and copy files, thanks to your instructions.

But I still have the terminal issue... Problem is I'm not using a Windows machine, but a Mac, and although TeraTerm works (with Wine), I can't get it to detect my Serial-to-USB adapter.

In fact, I tried several applications made for Mac - "CoolTerm", "SerialTools" and "Serial". They are all good but they don't have that option for 7-bit ASCII.

I have somewhere an old MS-DOS laptop with serial port, I guess I'll load some terminal software and give it a try.

Thanks again!

Re: New here, some questions

PostPosted: April 26th, 2015, 5:13 pm
by gmh
harnas wrote:In fact, I tried several applications made for Mac

Check out minicom. You can install it via Mac Ports, etc.

Re: New here, some questions

PostPosted: April 27th, 2015, 2:02 am
by gio74
Also ZTerm will work in Mac OS.
Luis I'm on a Mac too

Re: New here, some questions

PostPosted: April 27th, 2015, 10:30 am
by harnas
I installed this morning ZTerm - everything works great now :)


Re: New here, some questions

PostPosted: May 1st, 2015, 4:44 am
by harnas
I've been trying to load BASIC 4K from paper tape, but I'm having an issue here.

At the moment I want to transfer the tape image from my computer, it waits for the Altair to send a response, but it never arrives.

I tried .hex and .bin loading feature too, using the 8 bit transfer (not xmodem, as written in the manual), but again I can't do it. My computer is waiting forever for a request from the Altair, and won't start sending the file.

My serial cable is connected to the 2SIO port. All other features work ok.

Any idea?

Re: New here, some questions

PostPosted: May 1st, 2015, 7:04 pm
by AltairClone
The Altair bootstrap loaders and checksum loader don't transmit anything out the serial port as part of a normal load. The hex and bin load commands in the Configuration Monitor don't transmit anything either - just start sending the file.


Re: New here, some questions

PostPosted: August 20th, 2017, 5:56 am
by harnas
Well, this is embarrassing...

2+ years from my question about sending bin and hex files to the Altair via ZTerm, and I never got to do this.

I know how to transfer disk images, from and to the PC, and how to use the PCGET and PCPUT from a CP/M image.

But I looked everywhere, all possible options (handshake, transfer speeds, everything), and can't get to transfer bin, hex, or do something like updating the firmware. The computer always waits for a while and then shows an error.

When I choose the "Update the firmware" option, the Altair tells me "Send the update file now (8-bit, binary mode)...". I can't find this option, just XMODEM, YMODEM, ZMODEM and KERMIT. None of them worked so far.

There is also a "Transfer convert" option - I can choose between "Smart MacBinary", "Always MacBinary", "Binary Data" or "Text". I tried all of them, no success.

Could you tell me, step by step, how to do this? I'm sorry but I never understood your last answer - looks like my skills in this matter are really basic, I don't know what the checksum loader is...

Re: New here, some questions

PostPosted: August 22nd, 2017, 3:08 am
by harnas
I'm answering to myself :)

Finally, after 2 days of research, I could manage to update the firmware and load HEX and BIN images. I just had to try another terminal software and forget about ZTerm.

One of the options for Mac, among others, was an app called "Serial". With this program doing all this stuff was as easy as drag and drop.

So problem solved!